<hr>-elements

  • bibu
  • bibu's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
1 week 3 days ago #11188 by bibu
bibu created the topic: <hr>-elements
Hi everyone,

my maps are not displayed propper, whenever I´m using system-pagebreaks in my articles.

Using this code, the map is shown on the first page, but not after I click read more:

<p><img style="float: left; margin-right: 20px;" src="images/bibu/Elsass2017_1/liberty.png" alt="" width="10%" />Unser erstes gemeinsames Osterwochenende steht vor der Tür. Wir verzichten auf die Ostereierfärberei, schließlich fühlen wir uns dafür inzwischen ein wenig zu alt. </p>
<p>Was wir dort in den paar Tagen erlebt haben und was die Freiheitsstatue mit dem Elsass zu tun hat, dass erfahrt Ihr, wenn Ihr weiterlest. </p>
<p style="text-align: center;"> {zhgooglemap:2;10;ROADMAP;0;400}</p>
<hr id="system-readmore" /><hr title="Anreise am Karfreitag" alt="Anreise am Karfreitag" class="system-pagebreak" />


Using this code, the map is not displayed at all:

<p><img style="float: left; margin-right: 20px;" src="images/bibu/Elsass2017_1/liberty.png" alt="" width="10%" />Unser erstes gemeinsames Osterwochenende steht vor der Tür. Wir verzichten auf die Ostereierfärberei, schließlich fühlen wir uns dafür inzwischen ein wenig zu alt. </p>
<p>Was wir dort in den paar Tagen erlebt haben und was die Freiheitsstatue mit dem Elsass zu tun hat, dass erfahrt Ihr, wenn Ihr weiterlest. </p>
<hr id="system-readmore" />
<p style="text-align: center;"> {zhgooglemap:2;10;ROADMAP;0;400}</p>
<hr title="Anreise am Karfreitag" alt="Anreise am Karfreitag" class="system-pagebreak" />


Same with this code, no map at all, just a blank space instead:

<p><img style="float: left; margin-right: 20px;" src="images/bibu/Elsass2017_1/liberty.png" alt="" width="10%" />Unser erstes gemeinsames Osterwochenende steht vor der Tür. Wir verzichten auf die Ostereierfärberei, schließlich fühlen wir uns dafür inzwischen ein wenig zu alt. </p>
<p>Was wir dort in den paar Tagen erlebt haben und was die Freiheitsstatue mit dem Elsass zu tun hat, dass erfahrt Ihr, wenn Ihr weiterlest. </p>
<hr id="system-readmore" />
<hr title="Anreise am Karfreitag" alt="Anreise am Karfreitag" class="system-pagebreak" />

<p style="text-align: center;"> {zhgooglemap:2;10;ROADMAP;0;400}</p>

Thank you in advance for your help!

Please Log in or Create an account to join the conversation.

More
1 week 3 days ago #11189 by Dima
Dima replied the topic: <hr>-elements
Hi.
I think you can't correct display map in this case.
As I think it caused by:
When you have "read more", all your content breaks into two part, first you can see, the other you can't see (this section is not displayed until you click "read more" link). And in case section doesn't displayed, map div has not correct bounds, and map is not initialized correctly. Therefore you can't see map.
It is like display map on tabs.

I didn't create interface to refresh map (when you need to refresh map by program), because in this case you have to manage to add refresh code into your page source or control (for example, tab) or somewhere else. And in most cases it is not easy.

Probably, you can try little trick - create the other article for map, and in your first article call iframe tag with the map article. It is more complex, but I think it will work

Don't forget support my developments: post review in JED, donate ;)

Post your sites as examples into my directory
Zh GoogleMap: forum.zhuk.cc/index.php/forum/gm-user-s-sites
Zh YandexMap: forum.zhuk.cc/index.php/forum/ym-user-s-sites

Please Log in or Create an account to join the conversation.

  • bibu
  • bibu's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
1 week 2 days ago #11190 by bibu
bibu replied the topic: <hr>-elements
Thank you, Dima, for your fast response.

I´ll try your suggestion with the iframe later, but meanwhile I think it´s the pagebreak plugin, what causes the problems.

I´ve no problems displaying the map in articles, in which I use only a "readmore". The maps are displayed perfect even after clicking the readmore-button.

Only the use of "system-pagebrakes" is causing probs!

I found out, that maps are not dispayed on single article-pages. After clicking "Show All" in the article menu, the maps are shown proper.

Further I realized, that there are either tabs nor sliders displayed, after choosing those options in the pagebreak-plugin. There are headlines displayed, but sliders or tabs are not shown. BUT: In both options, the maps are displayed proper.

You wrote, that maps are not displayed on tabs. In my case, they are working!?

So I´ve changed the template to default (protostar), and yes, maps are not working on tabs in this case. But tabs and sliders are working!?

My conclusion is: using a different template, maps are displayed on tabs and sliders, but tabs and sliders are not working. Using the default template, maps and sliders are working, but maps not.

I´ll contact the developers of the template, maybe they have an idea. If they find a solution, I´ll let you know.

Thanks to you! Great work anyway!

Please Log in or Create an account to join the conversation.

Time to create page: 0.048 seconds

Donate


Go to top