https and kml layer?

  • lucv
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
7 months 14 hours ago #11466 by lucv
https and kml layer? was created by lucv
Hi,
I'm implementing zh GoogleMap on my website.
I created a simple map with plugin.
The map shows correctly.
But 2 problems remain:
1. breaks down https on the page (although I indicated https in options)
2. kml track won't show on the page.
My website page: www.walkitech.be/index.php/nl/gr-125-nl/27-gr-125-walcourt-nl
What am I doing wrong?

Please Log in or Create an account to join the conversation.

More
7 months 14 hours ago #11467 by Dima
Replied by Dima on topic https and kml layer?
Hi
As for 2 - i think you should try to download your KML as file from this service, upload file to your site folder and use URL to your site. I think your current call service, which draws its own map with KML path, it is not return only KML data.

As for 1 - what breaks. If you set https and restrict http by your server, for map call you should set using https in component options, there is a radio button (http|https)

Don't forget support my developments: post review in JED, donate ;)

Post your sites as examples into my directory
Google: forum.zhuk.cc/index.php/forum/gm-user-s-sites
Yandex: forum.zhuk.cc/index.php/forum/ym-user-s-sites
Baidu: forum.zhuk.cc/index.php/forum/bdm-user-s-sites

Please Log in or Create an account to join the conversation.

  • lucv
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
7 months 13 hours ago #11468 by lucv
Replied by lucv on topic https and kml layer?
Thanks for a prompt reply Dima,

Dima wrote: Hi
As for 2 - i think you should try to download your KML as file from this service, upload file to your site folder and use URL to your site. I think your current call service, which draws its own map with KML path, it is not return only KML data.
I did as you said. I put the KML file in site folder and referenced it as walkitech.be/images/gpxtracks/GR125-Walcourt.kml . It still does not show on the map.

As for 1 - what breaks. If you set https and restrict http by your server, for map call you should set using https in component options, there is a radio button (http|https)

In component options, the radio button is on https. Still getting 'not safe' message in Google browser.

Please Log in or Create an account to join the conversation.

  • lucv
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
7 months 13 hours ago #11469 by lucv
Replied by lucv on topic https and kml layer?
As for 2:
The track is now displaying.
I changed in the component options "Mootools" to "JQuery".

As for 1:
Still getting 'not safe' message.

Please Log in or Create an account to join the conversation.

  • lucv
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
7 months 10 hours ago #11470 by lucv
Replied by lucv on topic https and kml layer?
When I load the 'Roadmap' (GoogleMap), then my site stays https. That is what I want.
But when I load 'OSM' or 'OpenTopomap', then my site becomes 'not safe'. It says tiles are loaded via http link. That should be https link.
Can this be corrected in the scripts?

Please Log in or Create an account to join the conversation.

More
7 months 10 hours ago #11471 by Dima
Replied by Dima on topic https and kml layer?
I'll check it, and if I didn't use settings, I'll fix. Probably today evening. I'll post when I would do new release.

Don't forget support my developments: post review in JED, donate ;)

Post your sites as examples into my directory
Google: forum.zhuk.cc/index.php/forum/gm-user-s-sites
Yandex: forum.zhuk.cc/index.php/forum/ym-user-s-sites
Baidu: forum.zhuk.cc/index.php/forum/bdm-user-s-sites

Please Log in or Create an account to join the conversation.

Time to create page: 0.065 seconds

Donate


Go to top