Map won't load when HTTPS turned on

  • excaladmin
  • excaladmin's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
5 months 3 days ago - 5 months 3 days ago #11301 by excaladmin
excaladmin created the topic: Map won't load when HTTPS turned on
Hi Dima,

Thank you for a great extension. I am encountering one issue, though. I just updated my site to always load over HTTPS, and now the map on my site does not load due to mixed content. Looking in my browser console, I see the message:

Blocked loading mixed active content “http ://maps.googleapis.com/maps/api/js?key=[my_api_key]"

Would it be possible to get an updated version of the extension that either uses HTTPS URLs or parameterless URLs (e.g. "//maps.googleapis.com")? Or is there a setting in the extension that I missed that will fix this?

Thanks!
Ben
Last Edit: 5 months 3 days ago by excaladmin. Reason: Keep URL from being converted to a link.

Please Log in or Create an account to join the conversation.

  • excaladmin
  • excaladmin's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
5 months 3 days ago #11302 by excaladmin
excaladmin replied the topic: Map won't load when HTTPS turned on
Of course, I found the setting right after posting this. Sorry to bother you!

For anyone else who comes across this issue, go to Components > Zh GoogleMap, then click on the Options button on the right side of the page. There will be a field labeled Protocol, with radio buttons for HTTP and HTTPS. Select HTTPS and then save.

Please Log in or Create an account to join the conversation.

More
5 months 15 hours ago #11306 by Dima
Dima replied the topic: Map won't load when HTTPS turned on
OK

Don't forget support my developments: post review in JED, donate ;)

Post your sites as examples into my directory
Zh GoogleMap: forum.zhuk.cc/index.php/forum/gm-user-s-sites
Zh YandexMap: forum.zhuk.cc/index.php/forum/ym-user-s-sites

Please Log in or Create an account to join the conversation.

Time to create page: 0.070 seconds

Donate


Go to top