[SOLVED] Api key refuse to work after switching to https

  • Chabi01
  • Chabi01's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
More
1 month 3 days ago - 1 month 3 days ago #11432 by Chabi01
Chabi01 created the topic: [SOLVED] Api key refuse to work after switching to https
Hi Dima, Hi everybody,
On several site, i have a Google map api key working.
This key does not work anymore at the moment i switch on https. Note : i change in zhgooglemap the http to https but i always have an error on the api identification..

To be sure, i changed the key (regenerate), delete the key and create a new one, allow in many way the url : no success...

Is anybody has a clue on what is going on with these api keys ? Thanks :)

Xavier
Last Edit: 1 month 3 days ago by Chabi01.

Please Log in or Create an account to join the conversation.

More
1 month 3 days ago - 1 month 3 days ago #11433 by Dima
Dima replied the topic: Api key refuse to work after switching to https
Hi Xavier

What error have you got in console?

And can you give link to your page with map and this key?

Don't forget support my developments: post review in JED, donate ;)

Post your sites as examples into my directory
Zh GoogleMap: forum.zhuk.cc/index.php/forum/gm-user-s-sites
Zh YandexMap: forum.zhuk.cc/index.php/forum/ym-user-s-sites
Last Edit: 1 month 3 days ago by Dima.

Please Log in or Create an account to join the conversation.

  • Chabi01
  • Chabi01's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
More
1 month 3 days ago #11435 by Chabi01
Chabi01 replied the topic: Api key refuse to work after switching to https
Hi Dima :)
I forgot.... Happy new year :)
I deactivate the map on site as i cannot leave this like this.
I have this message shown : Google Maps API error: RefererNotAllowedMapError developers.google.com/maps/documentation...ot-allowed-map-error

So, Google tells me the url of my site is no longer accept for the api... As i told you, i try many things to regenerate, re-create, change url... nothing works... and i don't understand why as usually it works...
Thanks for your lights Dima :))
Xavier

Please Log in or Create an account to join the conversation.

More
1 month 3 days ago #11436 by Dima
Dima replied the topic: Api key refuse to work after switching to https
Thanks.
Probably you did mistakes.
Https - it is only way to interact, and API key - it is only API for maps. Probably you tried to create some other key, not JS Maps API. You should use HTTP-sources (web site) option selected
And HTTPS you can configure in server (SSL and so on)

Don't forget support my developments: post review in JED, donate ;)

Post your sites as examples into my directory
Zh GoogleMap: forum.zhuk.cc/index.php/forum/gm-user-s-sites
Zh YandexMap: forum.zhuk.cc/index.php/forum/ym-user-s-sites

Please Log in or Create an account to join the conversation.

  • Chabi01
  • Chabi01's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
More
1 month 3 days ago #11438 by Chabi01
Chabi01 replied the topic: Api key refuse to work after switching to https
Ok, i'm going to check all this...
Thanks Dima :)
Xavier

Please Log in or Create an account to join the conversation.

  • Chabi01
  • Chabi01's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
More
1 month 3 days ago #11439 by Chabi01
Chabi01 replied the topic: Api key refuse to work after switching to https
I clean up all the unused api key of my project so far : didn't found a duplicate for my site but at the end, the key is now accepted..
Maybe something wrong somewhere on Google.
Again, Dima, thanks for your time and your friendly help :)
Xavier

Please Log in or Create an account to join the conversation.

Time to create page: 0.071 seconds

Donate


Go to top