blank page

  • vientito
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
7 months 4 weeks ago #11939 by vientito
blank page was created by vientito
Hello,

i did a simple creation of a map and made sure I copied my google map key credentials and pasted in option. Yet by choosing the newly created component for display I only got a blank page. I turned on system debug console yet did not see anything unusual. Here is the link:

link

Please Log in or Create an account to join the conversation.

More
7 months 3 weeks ago - 7 months 3 weeks ago #11941 by Dima
Replied by Dima on topic blank page
Hi.
Look at browser console. You have error "JQuery is not defined"

wiki.zhuk.cc/index.php/Zh_GoogleMap_Trou...efined_error_message

Don't forget support my developments: post review in JED , donate ;)

Post your sites as examples into my directory User's Sites for apropriate extension
Last edit: 7 months 3 weeks ago by Dima.

Please Log in or Create an account to join the conversation.

  • vientito
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
7 months 3 weeks ago #11942 by vientito
Replied by vientito on topic blank page
first of all, thanks so much for your tips. By looking at details of my specific template, i notice that it has compressed the js files for optimization. By turning off that optimization of js files, it seems that it is able to see the subsequent jquery libraries. As a result, the map object now appears on page.

if you have a chance to look at my page again, you will notice there is a panel button on the middle right position. Clicking on it once will display list panel but clicking it again will not retract it. This behaviour is similar when i deploy your fullscreen template as well. Is this a bug or have I misconfigured some options?

Please Log in or Create an account to join the conversation.

More
7 months 3 weeks ago #11944 by Dima
Replied by Dima on topic blank page
You enable placemark list and want to display it in panel.
In this case I add Jquery-ui library (it needs jquery library).
And you can see that I load it. But, by your template jquery library loaded after mine, but it have to be loaded before.

Don't forget support my developments: post review in JED , donate ;)

Post your sites as examples into my directory User's Sites for apropriate extension

Please Log in or Create an account to join the conversation.

  • vientito
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
7 months 3 weeks ago #11948 by vientito
Replied by vientito on topic blank page
i am so sorry but i try adding this

/media/jui/js/jquery.js
/media/jui/js/jquery.ui.core.js

to additional js files to load in advanced option it does not seem to do the trick. maybe i am not fully understanding how to reload it jquery right ahead of you.

These are all the js files i have got on my system:

bitnami@lampstack-2-vm:/opt/bitnami/apps/joomla/htdocs/media/jui/js$ ls
ajax-chosen.js cms-uncompressed.js jquery-migrate.js jquery.simplecolors.min.js
ajax-chosen.min.js fielduser.js jquery-migrate.min.js jquery.ui.core.js
bootstrap.js fielduser.min.js jquery.minicolors.js jquery.ui.core.min.js
bootstrap.min.js html5.js jquery.minicolors.min.js jquery.ui.sortable.js
bootstrap-tooltip-extended.js html5-uncompressed.js jquery.min.js jquery.ui.sortable.min.js
bootstrap-tooltip-extended.min.js icomoon-lte-ie7.js jquery-noconflict.js sortablelist.js
chosen.jquery.js jquery.autocomplete.js jquery.searchtools.js treeselectmenu.jquery.js
chosen.jquery.min.js jquery.autocomplete.min.js jquery.searchtools.min.js treeselectmenu.jquery.min.js
cms.js jquery.js jquery.simplecolors.js

Specifically i have tried jquery.ui.core.min.js , jquery.js, jquery.ui.core.js in additional js files to add box

Please Log in or Create an account to join the conversation.

More
7 months 3 weeks ago - 7 months 3 weeks ago #11949 by Dima
Replied by Dima on topic blank page
First of all.
Try to disable optimization, to get clear examples.
1 - I think you should try not load /media/jui/js/jquery.ui.core.js, because there is only need one library
2 - look at image of your page source. I think optimizator loads scripts twice, and it can cause problems


Don't forget support my developments: post review in JED , donate ;)

Post your sites as examples into my directory User's Sites for apropriate extension
Attachments:
Last edit: 7 months 3 weeks ago by Dima.

Please Log in or Create an account to join the conversation.

Time to create page: 0.060 seconds

Donate


Go to top