HTTPS VS Zh GoogleMap

  • Harlock
  • Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
More
1 week 5 days ago #12775 by Harlock
HTTPS VS Zh GoogleMap was created by Harlock
Hi Dmitry,

A couple of days ago, I turned one of my clients site to the https protocol.
Today, my client warned me that the Google Map was not showing anymore (spinning wheel on the whole page).
I finally found out I had to set https protocol in the Zh GoogleMap configuration panel.
I also added my client's domain name with https to the Google API key.
Then, the Map showed again, great.

But… after that, I get a warning sign from browsers, letting me know this page (and this page only) was partially not secured.
I searched in the code and the only difference I can see with other pages is this :

.gm-style .transit-container{background-color:white;max-width:265px;overflow-x:hidden}.gm-style .transit-container .transit-title span{font-size:14px;font-weight:500}.gm-style .transit-container .transit-title{padding-bottom:6px}.gm-style .transit-container .transit-wheelchair-icon{background:transparent url(' maps.gstatic.com/mapfiles/api-3/images/mapcnt6.png ');background-size:59px 492px;display:inline-block;background-position:-5px -450px;width:13px;height:13px}.gm-style.gm-china .transit-container .transit-wheelchair-icon{background-image:url(' maps.gstatic.cn/mapfiles/api-3/images/mapcnt6.png ')}@media (-webkit-min-device-pixel-ratio:1.2),(min-resolution:1.2dppx),(min-resolution:116dpi){.gm-style .transit-container .transit-wheelchair-icon{background-image:url(' maps.gstatic.com/mapfiles/api-3/images/mapcnt6_hdpi.png ');background-size:59px 492px;display:inline-block;background-position:-5px -449px;width:13px;height:13px}.gm-style.gm-china .transit-container .transit-wheelchair-icon{background-image:url(' maps.gstatic.cn/mapfiles/api-3/images/mapcnt6_hdpi.png ')}}.gm-style .transit-container div{background-color:white;font-size:11px;font-weight:300;line-height:15px}.gm-style .transit-container .transit-line-group{overflow:hidden;margin-right:-6px}.gm-style .transit-container .transit-line-group-separator{border-top:1px solid #e6e6e6;padding-top:5px}.gm-style .transit-container .transit-nlines-more-msg{color:#999;margin-top:-3px;padding-bottom:6px}.gm-style .transit-container .transit-line-group-vehicle-icons{display:inline-block;padding-right:10px;vertical-align:top;margin-top:1px}.gm-style .transit-container .transit-line-group-content{display:inline-block;min-width:100px;max-width:228px;margin-bottom:-3px}.gm-style .transit-container .transit-clear-lines{clear:both}.gm-style .transit-container .transit-div-line-name{float:left;padding:0 6px 6px 0;white-space:nowrap}.gm-style .transit-container .transit-div-line-name .gm-transit-long{width:107px}.gm-style .transit-container .transit-div-line-name .gm-transit-medium{width:50px}.gm-style .transit-container .transit-div-line-name .gm-transit-short{width:37px}.gm-style .transit-div-line-name .renderable-component-icon{float:left;margin-right:2px}.gm-style .transit-div-line-name .renderable-component-color-box{background-image:url( maps.gstatic.com/mapfiles/transparent.png );height:10px;width:4px;float:left;margin-top:3px;margin-right:3px;margin-left:1px}.gm-style.gm-china .transit-div-line-name .renderable-component-color-box{background-image:url( maps.gstatic.cn/mapfiles/transparent.png )}.gm-style .transit-div-line-name .renderable-component-text{text-align:left;overflow:hidden;text-overflow:ellipsis;display:block}.gm-style .transit-div-line-name .renderable-component-text-box{overflow:hidden;text-overflow:ellipsis;display:block;font-size:8pt;font-weight:400;text-align:center;padding:1px 2px}.gm-style .transit-div-line-name .renderable-component-text-box-white{border:solid 1px #ccc;background-color:white;padding:0 2px}.gm-style .transit-div-line-name .renderable-component-bold{font-weight:400}

As you can see, some links are using http. Is that connected to my issue ?
Is this code generated by your plugin ?

Did I miss something ?
Thank you for your helpful answer !

Please Log in or Create an account to join the conversation.

More
1 week 5 days ago #12776 by Dima
Replied by Dima on topic HTTPS VS Zh GoogleMap
Hi.
In component options you need to set protocol to https.

And I think all will be fine.

Don't forget support my developments: post review in JED , donate ;)

Post your sites as examples into my directory User's Sites for apropriate extension

Please Log in or Create an account to join the conversation.

  • Harlock
  • Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
More
1 week 5 days ago #12777 by Harlock
Replied by Harlock on topic HTTPS VS Zh GoogleMap
Well, as I told you, this is what I've already done.

Please Log in or Create an account to join the conversation.

More
1 week 5 days ago #12778 by Dima
Replied by Dima on topic HTTPS VS Zh GoogleMap
I can see http and https links.
from what this links "maps.gstatic.com/mapfiles/transparent.png" are?
Probably it is counter or something not from Zh GoogleMap.

Don't forget support my developments: post review in JED , donate ;)

Post your sites as examples into my directory User's Sites for apropriate extension

Please Log in or Create an account to join the conversation.

More
1 week 5 days ago #12779 by Dima
Replied by Dima on topic HTTPS VS Zh GoogleMap
Can you give me link to page with map to check it?

Don't forget support my developments: post review in JED , donate ;)

Post your sites as examples into my directory User's Sites for apropriate extension

Please Log in or Create an account to join the conversation.

More
1 week 5 days ago #12780 by Dima
Replied by Dima on topic HTTPS VS Zh GoogleMap
You can mail me This email address is being protected from spambots. You need JavaScript enabled to view it.

Don't forget support my developments: post review in JED , donate ;)

Post your sites as examples into my directory User's Sites for apropriate extension

Please Log in or Create an account to join the conversation.

Time to create page: 0.065 seconds

Donate


Go to top