Development Error in Component!

  • Ginius
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
2 weeks 1 day ago #13724 by Ginius
Development Error in Component! was created by Ginius
It seems that the component has been written worng. All images of the placemarkers are plced in administrator/components/com_zhgoolemap/assets/icons

For most sites this will be working, but pro sites that are protecting the administartor directory with htaccess password have issues with it. The resoures could not be loaded.

Images that need to be showed on a site must always be either on /components and then their asset folder or in the /media/com_zhgooglemap/icons. Never, never place frontend CSS/images in the administrator folder.

How can I solve this that the icons are placed in the proper folder?

Best regards,

Arjen Schrijvers

Please Log in or Create an account to join the conversation.

More
2 weeks 23 hours ago #13725 by Dima

Please Log in or Create an account to join the conversation.

  • Ginius
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
2 weeks 19 hours ago #13726 by Ginius
Replied by Ginius on topic Development Error in Component!
Hi Dima,

great that solved the problem. Why don't you use that setting as default? It make more common and is more to the Joomla standard. Is the there a reason for it to do it on this way?

For now this issue is solved. Any plans that this wil also work in the new Joomla 4.0?

Please Log in or Create an account to join the conversation.

More
2 weeks 6 hours ago #13727 by Dima
Replied by Dima on topic Development Error in Component!
I did it when I started extension (in 2014), and due to size and for existing installation I decided not to change.

Don't forget support my developments: post review in JED , donate , help with thanslation ;)

Please Log in or Create an account to join the conversation.

Time to create page: 0.048 seconds

Donate


Go to top