Sorry no imagery here when using .kml file

  • Plemmenou
  • Plemmenou's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
2 years 11 months ago #6624 by Plemmenou
Plemmenou created the topic: Sorry no imagery here when using .kml file
Hello,

I am using a .kml file with your component for my site. But when loading the map the zoom level is too high and i have to zoom out in order to see the data of the .kml file. Is this because of the .kml file or do I have to change something on the component?

Please Log in or Create an account to join the conversation.

More
2 years 11 months ago #6626 by Dima
Dima replied the topic: Sorry no imagery here when using .kml file
Hi

Lets step by step:
1 - if map have one zoom, but it changed by KML file displaying - then you have some data in KML. To check it:
- just unpublish path with KML file, and check what zoom you have
2 - if you have some data in KML file, which is caused changing zoom:
- just go to path, and set in KML layer tab field "Layer Show Type" to Unchange. In this case I set to this KML file not change zoom to show all KML data.

- if you show KML file by map properties (it used default parameters), then move your setting (remove file from map properties, and create path with your file in KML section)

Don't forget support my developments: post review in JED, donate ;)

Post your sites as examples into my directory
Google: forum.zhuk.cc/index.php/forum/gm-user-s-sites
Yandex: forum.zhuk.cc/index.php/forum/ym-user-s-sites
Baidu: forum.zhuk.cc/index.php/forum/bdm-user-s-sites

Please Log in or Create an account to join the conversation.

  • Plemmenou
  • Plemmenou's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
2 years 10 months ago #6670 by Plemmenou
Plemmenou replied the topic: Sorry no imagery here when using .kml file
Thank you Dima,

I now have a working map with my kml layer on top of it with a working zoom level as expected. The problem was that I showed KML file by map properties and not by a path so it was using the default properties.

Thanks again.

Another issue I have is that it does not recognise the Regions. It is supposed that in my KML file I have set some regions to load in a defined zoom level (in google earth it works perfectly) but that is not happening in my zhgooglemaps. All the places are loaded together. Is something like that possible to happen?

Please Log in or Create an account to join the conversation.

More
2 years 10 months ago #6678 by Dima
Dima replied the topic: Sorry no imagery here when using .kml file
I load KML files as is. Probably in Earth there is option to show it on special zoom.
Today you can't control KML by zoom by my tools

Don't forget support my developments: post review in JED, donate ;)

Post your sites as examples into my directory
Google: forum.zhuk.cc/index.php/forum/gm-user-s-sites
Yandex: forum.zhuk.cc/index.php/forum/ym-user-s-sites
Baidu: forum.zhuk.cc/index.php/forum/bdm-user-s-sites
The following user(s) said Thank You: Plemmenou

Please Log in or Create an account to join the conversation.

Time to create page: 0.052 seconds

Donate


Go to top