The maps are no longer displayed on the pages

  • StefanoP
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
1 week 1 day ago #13970 by StefanoP
Hi, after the recent updates (I don't know if the extension or Joomla, since I made them both) in which they were inserted (as a module with assigned position and menu item).
Previously they worked perfectly, then at some point not anymore.
If I recall the map from the appropriate management of the Zh OpenStreetMap component, it is correctly displayed (see Image1).
I tried as an alternative to insert in the article the direct link to the desired map using the code {zhosmmap: 4; do not change; do not change; do not change}, but only an empty rectangle is displayed (see Image2) .
The Joomla version is 3.9.22 while the modules and components versions of Zh OpenStreetMap are the following:
K2 module for Zh OpenStreetMap - Map description 2.3.5.0
Zh OpenStreetMap module 2.1.5.0
Zh OpenStreetMap module - Article description map 1.2.0.0
K2 Plugin for Zh OpenStreetMap - Map Description 2.3.5.0
Zh OpenStreetMap Plugin 2.1.5.0
Zh OpenStreetMap Plugin - Map description article 1.1.0.0
Zh OpenStreetMap 7.2.0.0
Zh OpenStreetMap Package 7.1.0.0
Zh Template Map FullScreen 1.0.7.
I have no idea why no maps are no longer regularly displayed.
I have only your help left.
I thank you in advance.
Stefano
Attachments:

Please Log in or Create an account to join the conversation.

More
6 days 8 hours ago - 6 days 8 hours ago #13974 by Dima
Hi.
Probably you installed some other extension which initialized by onload function.
Go to admin panel, open component options and set map initialization type to JQuery ready event.

If it does not help, check browser console for errors. Probably there are some issues.

You can also give me link to page with map to analyse it.

Don't forget support my developments: post review in JED , donate , help with thanslation ;)
Last edit: 6 days 8 hours ago by Dima.

Please Log in or Create an account to join the conversation.

  • StefanoP
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
5 days 3 hours ago - 5 days 3 hours ago #13983 by StefanoP
Replied by StefanoP on topic The maps are no longer displayed on the pages
Hi Dima,
I followed your instructions, but with regards to the component settings everything was already set as you indicated. Using the browser error console, I was unable to trace the source of the problem.
But I realized one of the maps I was viewing on the site was working regularly. Comparing the parameters of this one with those of the other three, I noticed that the problem was related to the value indicated in the field "Display the contents of the popup" of the section "Advanced options". Changing from "Panel" to "Default" the maps magically reappeared. I have to be honest, they worked before regardless of the value entered here.
Thank you in advance for your availability.
Bye
Last edit: 5 days 3 hours ago by StefanoP.

Please Log in or Create an account to join the conversation.

Time to create page: 0.054 seconds

Donate


Go to top