Component failed to display the satellite view

More
1 year 5 months ago #14545 by Tanks
Hi Dima,

I ask Google Support to investigate more deeper about this error. They send me the following answer:

"When comparing your domain to the domain which hosts a demo for the plugin, we can see the same issue.
joomla.zhuk.cc/index.php/zhgooglemap-mai...n/gm-main-simple-map

It appears that the plugin is incorrectly modifying the URL which is used to request Maps satellite imagery. Here you can make a comparison between the two formats.
 
Website (failed request)
khms0.googleapis.com/kh ?[object Map Iterator]=[object Map Iterator]
Working sample request
khms0.googleapis.com/kh?v=908&hl=en-GB&x=9656&y=12316&z=15
I suggest working closely with the developer of the plugin to see you can locate how and where this behaviour is happening, I suspect that this is due to the ability of the plugin to switch between other third party map types and possibly services. I hope this information about URL will help you to resolve this issue

Best regards

Stephan

Please Log in or Create an account to join the conversation.

More
1 year 5 months ago #14546 by Dima
Hi.
It is Joomla! change something (header or etc)

Just 2 tests

1 - pure map HTML
joomla.zhuk.cc/test/simple_map.htm

2 - HTML text for map in joomla article, ie using joomla engine
joomla.zhuk.cc/index.php/zhgooglemap-mai...plugins-article-test

I think it is the same as for Street View
joomla.zhuk.cc/index.php/zhgooglemap-mai.../gm-main-street-view
You can see black box

I don't know what you need to set or change (joomla, apache or something else)

Don't forget support my developments: post review in JED , donate , help with translation ;)

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #14570 by Valroc
Bonjour,
Je rencontre exactement le même problème.
Est-ce qu’une solution a été trouvée ?
Merci par avance.

TRANSLATION :
Hello,
I'm having exactly the same problem.
Has a solution been found?
Thanks in advance.

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #14572 by Dima
Hi
In a few days I'll implement map in Joomla!4 and will try to check. If this error is still - I'll write to joomla support.

Don't forget support my developments: post review in JED , donate , help with translation ;)

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #14574 by Dima
Hi
Very strange behaviour.
I fixed it for Joomla!4 but did the same for Joomla!3 and it didn't fix.

Don't forget support my developments: post review in JED , donate , help with translation ;)

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #14577 by Valroc
Hi,
Indeed, there are no more satellite images. While waiting for a solution, I replace with another type of display.
Thank you for trying.

Please Log in or Create an account to join the conversation.

Time to create page: 0.073 seconds

Donate


Go to top